Tags: cimv2, connect, diagnostics, error, expand, item, items, microsoft, msdn, network, return, root, run, service, software, unable, wheni, wmi

Unable to connect to WMI service '\root\cimv2'

On Microsoft » Microsoft XP

1,727 words with 2 Comments; publish: Thu, 05 Jun 2008 11:16:00 GMT; (331109.38, « »)

When I run "Network Diagnostics", most of the items return "WMI Error". When

I expand an item, I see "Unable to connect to WMI service '\root\cimv2' ". I

have deleted the WBEM Repository, reinstalled wmi, and looked to make sure

permissions are set to "full".

What else can I try?

All Comments

Leave a comment...

  • 2 Comments
    • I ran the WMIDiag.vbs. After several tries/changes, it reports that WMI is

      working correctly, but I still get the "Unable to connect to WMI service

      '\root\cimv2' " error in the network diagnostics report.

      I'm still hopeful that someone can point me in the right direction. Thanks.

      "RJB" wrote:

      > When I run "Network Diagnostics", most of the items return "WMI Error". When

      > I expand an item, I see "Unable to connect to WMI service '\root\cimv2' ". I

      > have deleted the WBEM Repository, reinstalled wmi, and looked to make sure

      > permissions are set to "full".

      > What else can I try?

      #1; Thu, 05 Jun 2008 11:17:00 GMT
    • Repairing and re-registering the WMI

      http://windowsxp.mvps.org/repairwmi.htm

      Hope this helps. Let us know.

      Wes

      MS-MVP Windows Shell/User

      In news:DBB1ADFA-CFEE-42C0-BC88-1FBADD1EE248.windows-xp.questionfor.info.microsoft.com,

      RJB <RJB.windows-xp.questionfor.info.discussions.microsoft.com> hunted and pecked:[vbcol=seagreen]

      > I ran the WMIDiag.vbs. After several tries/changes, it reports that WMI

      > is working correctly, but I still get the "Unable to connect to WMI

      > service '\root\cimv2' " error in the network diagnostics report.

      > I'm still hopeful that someone can point me in the right direction.

      > Thanks.

      > "RJB" wrote:

      #2; Thu, 05 Jun 2008 11:18:00 GMT